Tokai TA35 - help please!?

General amplifier talk.

Moderator: ned

Post Reply
PGTips
Plucker
Posts: 2
Joined: Mon Sep 28, 2015 7:20 am
Location: West of England

Tokai TA35 - help please!?

Post by PGTips » Mon Sep 28, 2015 7:36 am

Hello all. I'm new here but I'm a proud owner of a Breezysound, 28 years and counting.

Anyhow, a couple of weeks back I picked up an old (1985?) TA 35 amp. The volume pot is a little scratchy but fine once dialed in. I can live with that for now. Last night however, I was playing through it with the master volume pull boost out to get the Champ style over driven sound. Whilst playing it just seemed to drop away and it sounds really weak and fluctuating in output. Does this sound familiar to anybody? Has a transistor blown or is it a case of getting some contact spray in there. I really haven't a clue when it comes to amps so any solid state advice would be greatly appreciated. Thank you.

PGTips
Plucker
Posts: 2
Joined: Mon Sep 28, 2015 7:20 am
Location: West of England

Post by PGTips » Wed Sep 30, 2015 9:09 am

Well folks...after a little knob turning and a gentle kick, everything seems to be okay now. So it seems to me nothing has "blown" but a deep clean may be in order.

felixcatus
Guitar God
Posts: 1345
Joined: Wed Nov 03, 2010 1:58 am
Location: Antwerp, Belgium

Post by felixcatus » Wed Sep 30, 2015 11:46 am

Good to hear that, simple solutions are always best. :wink:

Oh yeah, nice amp you have there and welcome to the forum.

mdvineng
Guitar God
Posts: 181
Joined: Tue Jun 27, 2017 7:01 am
Location: manchester

Post by mdvineng » Wed Nov 29, 2017 7:51 am

a tin of contact cleaner is what you need for the potentiometers to get the contacts working and crackle free

Post Reply